Skip to end of metadata
Go to start of metadata

Problem

Outbound calls are not maturing on the vega FXO gateway on seizing the port

Solution


  1. This document describe on resolving the issue where in the FXO port gets seized, but calls were not maturing

    1.      Call Flow:

    The calls coming into the gateway from SIP side (sip server/phone) where in it will seize the respective FXO port (based on the dial plan) connected towards PSTN line.

    2.      Symptoms of the issue:

    Check if you face below symptoms after the call seizes the FXO port.

     

    1. You get a dial tone after dialling the numbers 
    2. The telco provider gives you the message as number dialled is incorrect.

     

    Find below the basic log of a call from SIP to FXO POTS where FXO port 1 has got seized.

     

    LOG: 03/10/2016 07:50:33.232 ROUTER   (I)R0bC00 FINDROUTE profile:23(To_FXO) plan:1

                    call ref=[f10a00da]                            <-- SIP     [2,1] dest=NAME:0527781178,TEL:0527781178

                                                                                   --> POTS    [1,1] dest=TEL:0527781178

    admin  >

    LOG: 03/10/2016 07:50:33.235 ROUTER   (I)R0bC00 call proceeding

                     call ref=[f10a00da]

    admin  >

    LOG: 03/10/2016 07:50:36.300 POTS     (I)R03Cb6 connect call

                     call ref=[f10a00da]

    admin  >

    LOG: 03/10/2016 07:50:36.330 SIP      (I)R03C27 connect g711Ulaw64k (Profile 1 - Voice)

                    call ref=[00000000]

      3.      Solution:

    Make sure you have the latest firmware on the Vega 50

     Please make sure the line detection type has set properly based on your telco provider

    There are 3 ways in detecting the line, which are as follows

                     1) Tone detection

                 2) Polarity reversal detection

                 3) Loop current detection

    Also ensure that below parameter are also set

    1. Enable the Full Scale value for the POTS FXO Port Hardware Profile
    2. Adjust the Digital Tx gain to -3

     

     

    Once the above parameters are set as per your network requirement, make sure you have applied the same configuration by doing Apply and save the config

1 Comment

  1. I have this problem. In the article, you say to "Please make sure the line detection type has set properly based on your telco provider". I called my telco provider and talked to some engineers, and they had no clue what I was talking about. I am in the US. What are the typical settings that I need for a US telco provider???