Page tree
Skip to end of metadata
Go to start of metadata

To enable VMware Fencing, the VMware Perl SDK is required. Please download the VMware Perl SDK directly from VMware, or directly from this Wiki, and install it on both your HA Nodes. (You may need to create a VMware account to download the file, if downloading from VMware.)

After you have installed the SDK, you can test the installation by running the command 'fence_vmware_helper'.  If it asks you for a username, you have successfully installed it!

yum -y install openssl-devel
wget 'http://wiki.freepbx.org/download/attachments/19497718/VMware-vSphere-Perl-SDK-6.0.0-2503617.x86_64.tar.gz'
tar zxvf VMware-vSphere-Perl-SDK-6.0.0-2503617.x86_64.tar.gz
cd vmware-vsphere-cli-distrib
./vmware-install.pl

You should read and accept the licence agreement, and then accept the default for all questions.

Possible Issue: "VMware error:Server version unavailable at https://..." 

This is usually caused by an SSL Naming issue, and can be triggered when the hostname the VMware server responds with doesn't match the requested hostname. The easiest solution is to edit the files /usr/share/perl5/VMware/VICommon.pm and /usr/lib/vmware-vcli/VMware/share/VMware/VICommon.pm and insert the following line as the second line:

$ENV{PERL_LWP_SSL_VERIFY_HOSTNAME} = 0;

Note you must add that on both nodes.